View or search for all towns »

 

Subaru Owners - help with alarm issues!

Sorry to my neighbors that were woken up with an incessant car alarm this morning. I finally bought a battery for my fob, but it allowed me to set the alarm/lock but not disengage it. I don't know if it reset from being inactive so long, but putting the key in the ignition did nothing and everything I tried kept turning the alarm on. 

So far, from forums, I have gotten: 1) take the fuse out or 2) disconnect battery, put ignition on "on" and reconnect or 3) find the resent button under the steering console and hold for 15 seconds or 4) the manual explains how to reset, but it will make the alarm go off and I don't think I can follow the 32 steps while the alarm is stressing me out

Surely, with all the Subby's in town, someone has had this nightmare. How do I get the alarm to stop and get my car to start please? Thank you!!

Perhaps a call to Summit Subaru would be more informative?

I had a very similar issue on a 1998 Subaru that we owned.  The red 'reset' button did nothing to reset the alarm and engine deactivation.  I disconnected the battery, but I think what worked, in the end, was the deactivation timed out.  After that happened I took it to Summit Subaru and had them disarm the engine deactivation system.  Not sure what year your Subaru is, but guessing it is much newer so not sure this would even apply.  At the very least, as the person above suggested, if you have not done so already give Summit a call.

I had a somewhat similar experience last year with my 2013 Crosstrek- the remote start, triggered by the fob, started the car when I was not home.  I took it to Summit Subaru - three guys behind the counter rolled their eyes and laughed when I told them what happened.  I will never cross that threshold again.

The young technicians at Rossland Collision knew right away what had happened, disengaged the remote start as I never used it anyway, done.  I would suggest asking Brian or his technicians - top notch young men.

I like the guys at rossland collision. Will give them a try. Managed to get my car started but the unlock on the fob still doesn’t work. Judging by the internet responses, it’s a bit of a Subaru initiation.